How to fix an Onkyo receiver – TX-SR606 – By Ed

How to fix the HDMI switching issue that plagues the TX-SR606, HT-R960, and HT-R667 receivers. To fix it you will need 5 x 100uf at least 4v, which I got from mcmelectronics(.com), part number 31-8160. Others have purchased 100uf 35v electrolytic capacitors from Radio Shack (P/N 272-1028) for .29, with good results. Just be sure to put the negative side of the capacitor (it is marked) on the square side of the stamp on the circuit board where the old capacitor was removed. PLEASE, PLEASE, PLEASE: If you try the repair, please comment on what was happening before and after replacing the caps. For example (mine): Before: The receiver would take 5-10 min to hook up with the TV. Neither the video nor sound would work until the connection to the TV was made. The On Screen Display (OSD) didn’t work, and component video in would not work going out HDMI to the TV. The problems all started at different times, and got worse over time. After: HDMI handshake now works properly and connects after a second or two (so everything connects quickly). Component video and OSD work fine.

24 Comments

  1. Lee McIntyre November 6, 2012
  2. 331sbf November 6, 2012
  3. solyero November 6, 2012
  4. jiminboo November 6, 2012
  5. jiminboo November 6, 2012
  6. Ed Kern November 6, 2012
  7. Don Clark November 6, 2012
  8. Haizum74 November 6, 2012
  9. stripedog79 November 6, 2012
  10. ThePona15 November 6, 2012
  11. Zak Twobyfour November 6, 2012
  12. hoteltango1 November 6, 2012
  13. Ed Kern November 6, 2012
  14. Ed Kern November 6, 2012
  15. Haizum74 November 6, 2012
  16. Don Clark November 6, 2012
  17. telechara November 6, 2012
  18. telechara November 6, 2012
  19. Arno Vis November 6, 2012
  20. t1337Dude November 6, 2012
  21. gr8ride411 November 6, 2012
  22. Dizzydilly November 6, 2012
  23. Haizum74 November 6, 2012
  24. jezzamondo November 6, 2012